【Q&A】iOS / iPadOS や Android で PC と判定されてしまいサインオンできない
事象
セキュリティプロファイルで "スマートデバイスからのアクセスを許可" しているにも拘らず、 CloudGate UNO へサインオンしようとした際に、ユーザーIDが存在しない、停止、ロック、又はこのサービスへのアクセス条件を満たしていません。 とエラーが表示されるケースがあります。
原因
ブラウザ設定がデスクトップ表示(PC 版サイト)となっている場合、User Agent による自動判定 で PC からのアクセスと判定されます。
CloudGate UNO 管理者サイトのユーザーアクティビティ(下図)にて、「端末タイプ:PC」と判定されてアクセスが拒否されていることを確認できます。
対応策
- iOS / iPadOS や Android からモバイル表示のアクセスを許可する場合、ブラウザ設定をモバイル表示に切り替えます。
- iOS / iPadOS や Android からPC表示でアクセスを許可する場合、セキュリティプロファイルにて PC を許可します。
一部のタブレットではブラウザ設定をモバイル表示に切り替えても User Agent は PC として判定するケースが稀にあります。デバイスからのアクセスが必ずPCになる場合は PC として許可 します。
ブラウザ設定をモバイル表示に切り替える
デバイスのOSや、OSバージョン、ブラウザバージョンにより表示が異なります。
【iOS18】
ホーム画面「設定」 >アプリ >Safari >デスクトップ用 Webサイトを表示 >すべてのWebサイト を OFF にします。
サービスプロバイダーをデスクトップ表示で利用したい場合には、サインインを完了させサービスプロバイダーの画面が開いてから、Safariブラウザ >アドレスバー左端 「 」 をタップ >「
」をタップ >デスクトップ用Webサイトを表示 をタップして切り替えてます。
【iOS17, iOS16】
ホーム画面「設定」 >Safari >デスクトップ用 Webサイトを表示 >すべてのWebサイト を OFF にします。
サービスプロバイダーをデスクトップ表示で利用したい場合には、サインインを完了させサービスプロバイダーの画面が開いてから、Safariブラウザ >アドレスバー左端 「ぁあ」 タップ >デスクトップ用Webサイトを表示 をタップして切り替えてます。
Chrome >画面右上3点マーク >設定 >サイトの設定 >PC版サイト を OFF にします。また、「サイトの例外」に CloudGate UNO 及び CloudGate UNO と連携しているサービスプロバイダーが登録されている場合には削除します。
サービスプロバイダーをデスクトップ表示で利用したい場合、サインイン完了してサービスプロバイダーの画面が開いてから、Chrome >画面右上3点マーク >PC版サイトにチェック でデスクトップ表示に切り替えます。
PC として許可する
【デバイス証明書をご利用の場合】
セキュリティプロファイルにて「PC(証明書)」を許可することに加えて、CloudGate 証明書 を PC 用として発行し、デバイスへインストールします。
Cybertrust 証明書は、証明書を発行する際の OS 指定により自動でスマートデバイスとして登録される仕様です。Cybertrust 証明書を PC として発行してタブレットにインストールすることはできませんので、CloudGate 証明書を利用します。
【Cookie 制限をご利用の場合】
セキュリティプロファイルにて「PC(ブラウザー)」を許可し、端末登録し直してからサインオンします。